View Issue Details

IDProjectCategoryView StatusLast Update
0008752ADK-Xojo-V4RBRBDB APIpublic2020-03-16 17:00
ReporterDeltaworXAssigned ToIvan Smahin 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformINTELOSMAC OS OS Version*
Product Version10.0.x 
Target VersionFixed in Version10.1.x 
Summary0008752: .useSSL results in application not responding
DescriptionJust run into a problem with useSSL in Xojo via RBDB connection. I am trying to do this:


Dim DB As VRBDataBase
Dim mIsConnected As Boolean

DB = New VRBDataBase

DB.Host = "localhost"
DB.UserName = "sa"
DB.Password = "sa"
DB.Port = 15432
DB.PortSSL = 15434
DB.UseSSL
DB.databaseName = "testdb.vdb"

mIsConnected = DB.Connect


it results in a spinning beachball ("application is not responding" - probably due to high connectiontimeout) and I have to force quit the application. Ports are correct, database exists, ssl certificates are working (server is hosting sqlite dbs which are accessed via SSL)

Connection is working fine if I use the VConnection method:

Dim mVConnection As VConnection
mVConnection = New VConnection( "localhost", "sa", "sa", 15434 )
If mVConnection <> Nil Then
  mVConnection.UseSSL
  mVConnection.Open
End if


Is there an error in the useSSL implementation in RBDB API?

Tested with Xojo 2019r3.1, Valentina ADK for Xojo 10.1 and VServer 10.1 on macOS 10.14.6
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-03-16 16:54 DeltaworX New Issue
2020-03-16 17:00 Ivan Smahin Assigned To => Ivan Smahin
2020-03-16 17:00 Ivan Smahin Status new => resolved
2020-03-16 17:00 Ivan Smahin Resolution open => fixed
2020-03-16 17:00 Ivan Smahin Fixed in Version => 10.1.x