1. Findomo
  2. Valentina Reports ADK
  3. Dienstag, Februar 04 2020, 12:56 PM
  4.  Abonnieren via E-Mail
Hi,
I am migrating an application from xojo 2019 R2 to xojo 2019 R3 on windows 10
With version 2019 r2 all reports worked fine. We tested all in a preproduction environment
With xojo version 2019 r3 and Reports ADK as of january 2020 I get (for all valentina project files) the following error:
365829: File "UNKNOWN" is not open.
Testing in debug mode does not report any error and works fine. I get the error only after build, invoking the reportcount function
Also, if I bypass the error and try to execute a report, the application exits without notice.



Here is my code:

Dim i As Integer
Dim count As Integer
Dim repName as string
try

mAppFolder = getFolderItem( "" )

#if DebugBuild
mProjectPath =new FolderItem( "c:/xojobiapro/reports/cqualita.vsp",folderitem.PathModes.Shell)
#else
mProjectPath=getfolderitem("";).Child("reports";).child("cqualita.vsp";)
#endif
mProject = new VProject( mprojectpath )

mProject.Open()


if mProject <> nil then
count = mProject.ReportCount()
end if


pbPreview.Enabled = true
pbSaveAsPDF.Enabled = true
doreportbutton.enabled=true


Exception err as VException
MsgBox Str(err.ErrorNumber) + ":" + err.Message+" "+mProjectPath.NativePath
end



Here is the valentina LOG

Valentina_SetDebugLevel...
PARAM: inLevel = 3
return

VProject_Ctor_Local...
PARAM: instance = 89006824
PARAM: inFi = 244182184
return

VProject_Open...
PARAM: instance = 89006824
return

VProject_GetReportCount...
PARAM: instance = 89006824
ERROR: 0x59505 File "UNKNOWN" is not open.

return res = 0


Can you help me?

Thanks!
Anhänge
Kommentar
There are no comments made yet.
Findomo Akzeptierte Antwort
Solved!

The problem was related to the vccomponents dll's that where not correctly updated. I copied all the files from C:\Program Files (x86)\Paradigma Software\vcomponents_win_vc
to the application folder and that solved the problem

thanks to all!
Kommentar
There are no comments made yet.
François Van Lerberghe Akzeptierte Antwort
I had this error this morning (Xojo 2019r1.1 - Valentina 9.5.3 - no projet, only database) in SQL query. Deleting the index file and opening again the database solved the problem.
Kommentar
There are no comments made yet.
  • Seite :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories