1. Beatrix Willius
  2. Valentina Database ADK
  3. Montag, Juni 28 2021, 11:01 AM
  4.  Abonnieren via E-Mail
A user has problems opening an archive. He gets the above error. Here is what he did:

I also have a Synology NAS where I wanted to put the archive. The SMB folder is mounted via the Apple automounter. When I specify this for the archive I get an error message. However, if I mount the folder using the normal mount behavior of macOS, archiving works, although both mounts address the same target. Then even when I reopen the Diskstation folder it mounts when it didn't.


My app uses a shell path to write the location of the database to prefs and uses the path to open the database. For the user the path is "/Volumes/Privat/MailArchiverX/MailArchiv.vdb".

Do you have any idea what might cause such a problem. User is using Catalina with Valentina 10.5.3. The database is a local and not a server one.
Kommentar
There are no comments made yet.
Ivan Smahin Akzeptierte Antwort
It seems it is because we still use functions like FSPathMakeRef, FSGetCatalogInfo inside. For SMB resources we need something like fileURLWithPath...
Please report it to the Mantis.
Kommentar
There are no comments made yet.
Beatrix Willius Akzeptierte Antwort
Kommentar
There are no comments made yet.
  • Seite :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories