1. Fotis Georgiadis
  2. Valentina Reports ADK
  3. Dienstag, Juli 12 2016, 01:52 PM
  4.  Abonnieren via E-Mail
Hello,
On a Xojo application I print using Valentina Reports ADK (latest version). Now on all my test machines works fine. On a specific site I get "Report Error 611604: Datasource error: "[FreeTDS] Unable to connect: localhost :: worktimer".

Using Xojo 2016 Release 1.1, V4RB 6 (V: 6.5.8) Connecting to MSSQL Server, Windows 7 Enterprise...

Any ideas?
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
I did a clean install of SQL Server Express 2012 and VStudio 8.3.2.

1. Turned on TCP/IP
2. Defined 1433 for TCP Port option in IPAll group
3. Restarted the server
4. Connection from the Valentina Studio established successfully

Do you have any additional antivirus/firewall? In our recent case, it was KIS that prevented VStudio connections while other applications were able to connect.
Anhänge
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
The description of the datasource strings can be found here.

odbc://dsn = 'access', user = 'name', password = '123'
Kommentar
There are no comments made yet.
Alexis Colon Lugo Akzeptierte Antwort
Hi
how i can run using ODBC the reports from XOJO web app.

how i change from "mssql://host='localhost\\SQLEXPRESS' port='1433' dbname='ADG' user='adgadmin' password='dragon'" to use ODBC
Kommentar
There are no comments made yet.
Alexis Colon Lugo Akzeptierte Antwort
i try telnet servername 1433 and works but VS no connect to MSSQL Express 2012
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hi Alexis,

ODBC is the completely different way.
Don't you have some strict firewall/antivirus installed?
For example, KIS may block even the local connection, that was discovered recently.

Also, please check that the port is assigned for your localhost connection, like on my previous screenshot.
Kommentar
There are no comments made yet.
Alexis Colon Lugo Akzeptierte Antwort
Hi Sergey
VS works but using ODBC but if i use the MSSQL connect from VS no works
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
So now you can connect from VStudio and generate a report, right? What did you change and what are the current settings?
Also, you can use the context menu on the data source on the project tab to view the data source string you can use in code.
Please add this info.
Kommentar
There are no comments made yet.
Alexis Colon Lugo Akzeptierte Antwort
i connect with VS but on xojo is the same error on this code >> data = mReport.PrintToBuffer(EVReportPrintType.kToHTML, 1 )
Kommentar
There are no comments made yet.
Alexis Colon Lugo Akzeptierte Antwort
can i go VS old version and adk reports this works before 8.0.2
Kommentar
There are no comments made yet.
Alexis Colon Lugo Akzeptierte Antwort
is any other way to check the problem ?
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
SSMS may connect using the different way.
Have you defined the port number in the SQL Server Configuration Manager? Please show your settings like on my screenshot
Anhänge
Kommentar
There are no comments made yet.
Alexis Colon Lugo Akzeptierte Antwort
same error
my VST PRO v 8.0.2
Anhänge
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Please try to leave the Server input field empty
Kommentar
There are no comments made yet.
Alexis Colon Lugo Akzeptierte Antwort
MS Management Studio
Anhänge
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
MS Visual Studio? Or SQL Management Studio?
Please show the screenshots of their connect dialog and the Valentina Studio.
Kommentar
There are no comments made yet.
Alexis Colon Lugo Akzeptierte Antwort
i try to connect with VS and no connect but using MS Studio user sa and pass work.
i'am using localhost
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hello Alexis,

Did you try to connect from the Valentina Studio? It's much easier to try different server settings.
Kommentar
There are no comments made yet.
Alexis Colon Lugo Akzeptierte Antwort
Hi
i have same error and enabled TCP/IP if anable
RepStrConn="mssql://host='localhost\\SQLEXPRESS' port='1433' dbname='ADG' user='adgadmin' password='passs'"
Kommentar
There are no comments made yet.
Jochen Peters Akzeptierte Antwort
thanks
Sergey i fix it with enable tcp/ip on ms sql express

thanks you are big help
:D
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hi Alexis,

So have you enabled TCP/IP protocol?
Kommentar
There are no comments made yet.
  • Seite :
  • 1
  • 2


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories