1. nimrod
  2. Valentina Studio
  3. Montag, März 19 2018, 08:49 AM
  4.  Abonnieren via E-Mail
Valentina Studio is frequently going into %100 CPU (i have 8 cores, I get 800% CPU, probably since it uses all threads it can take).

I'm not sure what is the cause of that, I'm using it on MacBook pro with MacOS Sierra and MariaDB:
mysql Ver 15.1 Distrib 10.2.7-MariaDB, for osx10.12 (x86_64) using readline 5.1

this has been happening for quite a few versions of Valentina, and all I can do is kill it and start over.

any ideas?
Kommentar
There are no comments made yet.
nimrod Akzeptierte Antwort
awesome :) thank you!
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hello,

The version 8.3 is available for download
Kommentar
There are no comments made yet.
nimrod Akzeptierte Antwort
Excellent news. cant wait...
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Yes, I think I found a solution.
The fix will be available in the version 8.3.
Kommentar
There are no comments made yet.
nimrod Akzeptierte Antwort
Good news Sergey!

Hope you’ll find a way to resolve it,

Keep me posted:)
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hello,

Thank you, finally, I was able to reproduce the problem.

I switch the Wi-Fi connection from the router to the personal hotspot of the smartphone and back and after a few iterations, the CPU load increased.
Kommentar
There are no comments made yet.
nimrod Akzeptierte Antwort
what I did, and usually do is:
1. use the app, open a remote connection via SSH.
2. leave it connected, moved to other applications.
3. leave the app open, sometimes for days. I also take the machine with me from work<->home, so a network disconnection is bound to occur.
4. suddenly I hear the fan doing some heavy lifting... opening the task manager reveals valentina studio is on 400%+ cpu...

hope this answers your question.
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hello,
thank you, the problem again is during the stopping the SSH stream.

Did you close the connection before making a sample?
Kommentar
There are no comments made yet.
nimrod Akzeptierte Antwort
Well, happening again just now.

here's the sample process, if you care to check it...
Anhänge
Kommentar
There are no comments made yet.
nimrod Akzeptierte Antwort
As far as I can tell, it didn't happen since I updated the studio, but I cannot say for sure, because it used to happen only once in a while, so if it happens again, I will update here and upload a new process sampling.

thanks,
Nimrod
Kommentar
There are no comments made yet.
Lynn Fredricks Akzeptierte Antwort
Did that solve your problem?
Kommentar
There are no comments made yet.
nimrod Akzeptierte Antwort
Super!
thank you so much!!!
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hello,

An updated version is available for download:
http://valentina-db.com/download/release/mac_64/

At least the CPU usage should be decreased.
Kommentar
There are no comments made yet.
nimrod Akzeptierte Antwort
Hello, and thank you for looking into it and investigating.

yes, I definitely use SSH to connect, the servers are located in Europe and USA, and i work from Israel.

I'm also always wireless, most time via wifi to my office/home DSL router.
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hello,

Unfortunately, still unable to reproduce exactly this problem.
Only the high resource usage to support SSH connection.

So there must be some SSH error.
Do you connect via SSH when it happens?
What kind of connection is used - ethernet/wireless?
How far is this server located?
Kommentar
There are no comments made yet.
nimrod Akzeptierte Antwort
Hi,

here's a sampled process.

During the sampling I disconnected from all mysql connections, and its stable on 200% cpu.
Anhänge
Kommentar
There are no comments made yet.
nimrod Akzeptierte Antwort
ok, I will sample it and send results.
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hello,

You kill the application - so it hangs and isn't responding, right?

Could you please try to Sample Process in the Activity Monitor.app for the Valentina Studio process the next time you'll notice this problem?
Anhänge
Kommentar
There are no comments made yet.
  • Seite :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories