1. Smart City doo
  2. Valentina Server
  3. Tuesday, January 28 2020, 09:45 AM
  4.  Subscribe via email
Drop indexed suspended : Field subfolders.path is still indexed because of Unique or PK constraint.

Sometimes I get this warning message in vServer log.

How to avoid it?

regards,
Zoran
Comment
There are no comments made yet.
Ivan Smahin Accepted Answer

set property WarningMode to 0;
-- your code
set property WarningMode to 1;
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Server
  3. # 1
Smart City doo Accepted Answer

set property WarningMode to 0;
-- your code
set property WarningMode to 1;

No, I don't want to avoid warning messages in log. :)
Can you explain me what this message means?

regards,
Zoran
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Server
  3. # 2
Ivan Smahin Accepted Answer
That message is result of attempt to turn off "indexed" flag for the "unique" field.
Unique field is always indexed and such call like

unique_field.put_Indexed(false)

do nothing except the warning.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Server
  3. # 3
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.