1. skipper hosting
  2. Valentina Studio
  3. Tuesday, September 26 2017, 07:42 PM
  4.  Subscribe via email
MAS 7.4.1 on Sierra 10.12

I have managed to get VS to connect to my server via a SSH tunnel. This, however, is a tenuous connection, as the following happens each time I start VS:

I have a connection bookmark with all the necessary servers and passwords set, as well as the ssh private key file to use with the connection. I have verified the credentials numerous times inside and outside VS (ie via terminal and other db management software packages) -- the credentials are correct.

At app startup, the SSH tunnel fails to connect with 'Authentication by public key failed!'. Dismissing this dialog brings up the connection properties for the failed bookmark. At this point. I can cancel that dialog and continuously try to connect with the book mark, as-is -- same failed result each time. However, if when the connection properties dialog comes up, I reselct the same private-key file already pointed to in the dialog, the connection goes through just fine.

the problem is not with the information, it is that the bookmark does not seem to properly connect back to the designated private key file as set. The path value before and after refreshing the key file is exactly the same. Something is happening behind the scenes to that the 'stored' value is treated differently than a 'fresh-set' value.

Thanks
Comment
There are no comments made yet.
Sergey Pashkov Accepted Answer
Hello,

I think the problem is in the Mac App Sandbox restricting an access to the key file after restarting the application.

Please try to add the folder with the key to Allowed Locations in the Preferences dialog.

And I have to recheck why it is not asked automatically to add this location.
References
  1. http://valentina-db.com/docs/dokuwiki/v7/doku.php?id=valentina:products:vstudio:help:dialogs:preferences:allowed_locations
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 1
skipper hosting Accepted Answer
(solved)

Thanks, adding the folder location as indicated does indeed allow the bookmark to connect at app launch.

I was unaware of the 'allowed locations' setting, and would likely have never noticed/considered that as a possible vector given the symptom and resultant error message (all suggesting an external communication problem).
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 2
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories