1. Cecilio
  2. Report Editor
  3. Sunday, March 11 2018, 08:55 AM
  4.  Subscribe via email
Hi.
The currency format does not show decimals.
ejmplo: 4.15 you see how 4.00 €

Instead of seeing 15 shows 00

How can it be solved without putting a pattern on all the fields?
Or can you create a standard pattern that replaces the one of currency format?

I use linux.
Comment
There are no comments made yet.
Sergey Pashkov Accepted Answer
Hi Cecilio,

Have you already tried a new build?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 1
Sergey Pashkov Accepted Answer
Hello Cecilio,

The fix is available in the version 8.6.3:
http://valentina-db.com/download/release/lin_64/

As always it is necessary to update the Valentina Studio and Xojo plugin to see changes.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 2
Sergey Pashkov Accepted Answer
We reproduced the problem and working on the solution now.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 3
Cecilio Accepted Answer
I have changed the format and so: #.##0,0# so it works
But I'm worried that other computers stop going.
Spanish language
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 4
Sergey Pashkov Accepted Answer
I think the problem is in the locale: when the conversion from string to number happens a wrong decimal-point character is expected.
I'll check it.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 5
Cecilio Accepted Answer
MariaDB
if execute SELECT the format is 12.50 for example. All number have decimals
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 6
Sergey Pashkov Accepted Answer
Hello, Cecilio,

Please add details - what database is used, is everything on Linux?

If you execute SELECT in the SQL Editor - what is the format of these values?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 7
Cecilio Accepted Answer
Hello, the problem persists.
Decimals are not seen in preview or in real time.

I have tried to type "Number" and format: "#, ## 0. ## €" Decimals are not seen either.

What can be the problem?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 8
Cecilio Accepted Answer
Resolved. It only looks like this in the report editor, preview option.

In real it prints correct: 4.15 €

Excuse me.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 9
Sergey Pashkov Accepted Answer
Hi Cecilio,

That's strange. Looks like the format is not recognized.
What database is used?
If you execute select with this field you get 4.15 with a dot as the separator, right?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 10
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories