1. nimrod
  2. Valentina Studio
  3. Monday, March 19 2018, 08:49 AM
  4.  Subscribe via email
Valentina Studio is frequently going into %100 CPU (i have 8 cores, I get 800% CPU, probably since it uses all threads it can take).

I'm not sure what is the cause of that, I'm using it on MacBook pro with MacOS Sierra and MariaDB:
mysql Ver 15.1 Distrib 10.2.7-MariaDB, for osx10.12 (x86_64) using readline 5.1

this has been happening for quite a few versions of Valentina, and all I can do is kill it and start over.

any ideas?
Comment
There are no comments made yet.
Sergey Pashkov Accepted Answer
Hello,

You kill the application - so it hangs and isn't responding, right?

Could you please try to Sample Process in the Activity Monitor.app for the Valentina Studio process the next time you'll notice this problem?
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 1
nimrod Accepted Answer
ok, I will sample it and send results.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 2
nimrod Accepted Answer
Hi,

here's a sampled process.

During the sampling I disconnected from all mysql connections, and its stable on 200% cpu.
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 3
Sergey Pashkov Accepted Answer
Hello,

Unfortunately, still unable to reproduce exactly this problem.
Only the high resource usage to support SSH connection.

So there must be some SSH error.
Do you connect via SSH when it happens?
What kind of connection is used - ethernet/wireless?
How far is this server located?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 4
nimrod Accepted Answer
Hello, and thank you for looking into it and investigating.

yes, I definitely use SSH to connect, the servers are located in Europe and USA, and i work from Israel.

I'm also always wireless, most time via wifi to my office/home DSL router.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 5
Sergey Pashkov Accepted Answer
Hello,

An updated version is available for download:
http://valentina-db.com/download/release/mac_64/

At least the CPU usage should be decreased.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 6
nimrod Accepted Answer
Super!
thank you so much!!!
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 7
Lynn Fredricks Accepted Answer
Did that solve your problem?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 8
nimrod Accepted Answer
As far as I can tell, it didn't happen since I updated the studio, but I cannot say for sure, because it used to happen only once in a while, so if it happens again, I will update here and upload a new process sampling.

thanks,
Nimrod
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 9
nimrod Accepted Answer
Well, happening again just now.

here's the sample process, if you care to check it...
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 10
Sergey Pashkov Accepted Answer
Hello,
thank you, the problem again is during the stopping the SSH stream.

Did you close the connection before making a sample?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 11
nimrod Accepted Answer
what I did, and usually do is:
1. use the app, open a remote connection via SSH.
2. leave it connected, moved to other applications.
3. leave the app open, sometimes for days. I also take the machine with me from work<->home, so a network disconnection is bound to occur.
4. suddenly I hear the fan doing some heavy lifting... opening the task manager reveals valentina studio is on 400%+ cpu...

hope this answers your question.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 12
Sergey Pashkov Accepted Answer
Hello,

Thank you, finally, I was able to reproduce the problem.

I switch the Wi-Fi connection from the router to the personal hotspot of the smartphone and back and after a few iterations, the CPU load increased.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 13
nimrod Accepted Answer
Good news Sergey!

Hope you’ll find a way to resolve it,

Keep me posted:)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 14
Sergey Pashkov Accepted Answer
Yes, I think I found a solution.
The fix will be available in the version 8.3.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 15
nimrod Accepted Answer
Excellent news. cant wait...
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 16
Sergey Pashkov Accepted Answer
Hello,

The version 8.3 is available for download
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 17
nimrod Accepted Answer
awesome :) thank you!
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 18
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories