1. Fotis Georgiadis
  2. Report Editor
  3. Sunday, March 20 2016, 01:10 PM
  4.  Subscribe via email
I am creating a new project, a new data source to an MSSQL Server db.
Then I create a query, which in the "Test" tab shows the results correctly.
When I create a simple report to this datasource / query, I get an error with the message "Please set valid source data" and in the "title" it says: "Kernel error 0x95514. Datasource error: "DB-Library error: Column number out of range Operating-system error: No error"
Am I doing something wrong (or not doing something)? Is there another problem?
Comment
There are no comments made yet.
Sergey Pashkov Accepted Answer
Hello, Fotis

What version of MS SQL Server are you using?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 1
Fotis Georgiadis Accepted Answer
Hi Sergey and thank you for your reply,

This specific machine has SQL Server 2014 (Express)

However, the reports should regularly run (when I include them in Xojo Apps) on SQL Server 2008 R2

Does it have to do with the server version? As I said, the query in the test tab shows the results with no problem...
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 2
Sergey Pashkov Accepted Answer
Not sure yet. Need to check with SQL Server 2014.

I've tried reports with SQL Server 2012 and it worked.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 3
Fotis Georgiadis Accepted Answer
I will also check with SQL Server 2008 R2 and get back to you...
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 4
Fotis Georgiadis Accepted Answer
I get the exact same error in SQL Server 2008.

I have just installed Valentina Studio (Pro) 6.3.5.
Should I install something else as well? I remind you that creating a similar report for Postgres works fine.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 5
Sergey Pashkov Accepted Answer
And what is the query?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 6
Fotis Georgiadis Accepted Answer
The query is:

SELECT E_INVENTORY.ei_number, eirtl_omada, eirtl_name_short, eirtl_price_sal
from E_INVENTORY, E_INV_RETAIL
WHERE E_INV_RETAIL.ei_number = E_INVENTORY.ei_number
order by eirtl_omada, eirtl_name_short

(very simple)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 7
Fotis Georgiadis Accepted Answer
I seem to have 2 problems.

1. If I select a single table, it seems to work (initial tests)
2. If I select a view or more than one tables in the query, it doesn't work!
3. In the case it works it doesn't show the correct codepage (note that in the TEST tab of the query it displays correctly!).

Any ideas?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 8
Fotis Georgiadis Accepted Answer
Finally it seems that the only problem is when the query has more than 1 table.
Could you please verify this?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 9
Sergey Pashkov Accepted Answer
I don't have such issue with two tables in one query.

Both tables are in one schema dbo, right?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 10
Fotis Georgiadis Accepted Answer
Sure it is in the same schema (dbo).

I wonder why this happens to me... I will do more test.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 11
Sergey Pashkov Accepted Answer
Still can't reproduce with my test database.

Is it possible to get a dump of this db, or at least schema dump?
And a query for report which doesn't work.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 12
Fotis Georgiadis Accepted Answer
I attach the DB (SQL Server 2014) and the Valentina Project.
Hope you find something out!
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 13
Fotis Georgiadis Accepted Answer
I attach the DB (SQL Server 2014) and the Valentina Project.
Hope you find something out!
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 14
Fotis Georgiadis Accepted Answer
You can get the DB (SQL Server 2014) and the Valentina Project from this link.
Hope you find something out!
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 15
Sergey Pashkov Accepted Answer
Thank you! We'll try to find out what's wrong ASAP
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 16
Sergey Pashkov Accepted Answer
One problem was in reading the Numeric field value.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 17
Sergey Pashkov Accepted Answer
And what about incorrect codepage, where do you see it?

Also, there is a specific detail for SQL Server. Source query may be executed as a subquery in some cases and therefore it fails if contains ORDER BY. So it is better to define sorting not in the query, but in the report. Otherwise, obviously, it is necessary to use TOP in the source query.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 18
Fotis Georgiadis Accepted Answer
Hi Sergey,

I removed the numeric field (from both the query and the report), I also removed the ORDER BY from the query, but still get the same error!

I remind you that the same query shows the data with no problem in the "TEST" tab and the same project works with no problem (creates the report) if I connect to PostgreSQL database...
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 19
Sergey Pashkov Accepted Answer
Hi, Fotis,

Maybe other number data types affected. Write the query that you use please, and I'll check if it is fixed now.

Different results because the test is executed by VStudio, not by VReport.
Different code works there.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 20
  • Page :
  • 1
  • 2


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories