1. Darrin DiSimo
  2. Valentina Database ADK
  3. 金, 3月 25 2022, 04:37 AM
  4.  メールで購読
I am new to Valentina. I am trying to access a Valentina server DB via ODBC. It works fine when I do not encrypt the DB, but when I encrypt the DB I get the following error:

[Paradigma Software][Valentina ODBC][Valentina engine](0x61502) Specified encryption key is wrong.

I am trying to open it with the following connection string:

Driver={Valentina ODBC Driver};Data Source=ODBCSource;Host=localhost;Port=15432;Database=testDB;UID=sa;PWD=sa;DataEncryptionKey=1234

I know I am using the correct Encryption key. When the DB is not encrypted it works fine. I have read through the documentation, but did not find anything in about how to specify the encryption key in the connection string.

I have tried different keywords for the encryption key (EncryptionKey, DataEncryptionKey, etc) with no luck.

Thank you in advance for any help.

Darrin DISimo
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hello Darrin,

Encryption is not supported in ODBC driver, I think we can add it in the next version.
コメント
There are no comments made yet.
Ruslan Zasukhin 承諾済みの回答
Hi Darrin,

I wonder why you use ODBC for VServer?
some special language or some third-party tool?
コメント
There are no comments made yet.
Darrin DiSimo 承諾済みの回答
Using VB6 so there is no direct interface to Valentina.
コメント
There are no comments made yet.
Ruslan Zasukhin 承諾済みの回答
For VB6 we do have VCOM - this is exactly for VB6 product.
Please check it.

1) See URL to wiki below.

2) Interesting, in WIKI said:
Valentina COM is no longer updated as of Valentina Release 7.5.9 on Feb 9, 2018.

But I see vcom_12 in the release folder:
http://www.valentina-db.com/download/release/win_32
参照
  1. http://valentina-db.com/docs/dokuwiki/v12/doku.php?id=valentina:products:adk:vcom:vcom
コメント
There are no comments made yet.
Darrin DiSimo 承諾済みの回答
Thank you. I will check out VCOM.
コメント
There are no comments made yet.
Darrin DiSimo 承諾済みの回答
Thank you all for the information. I checked out VCOM, but it would probably require too much rewriting. Hopefully the next version of ODBC has the Encryption option.

Thank you.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
ODBC Encryption is not ready yet but I'm working on it.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hello Darrin,

I created a test build with two new encryption parameters:
DataEncryptionKey
StructureEncryptionKey

You can try it or wait for the next version.
添付ファイル
参照
  1. https://www.dropbox.com/s/6wrarn5tfu4wca0/vodbc_standalone_x64_12_win.exe?dl=0
コメント
There are no comments made yet.
Darrin DiSimo 承諾済みの回答
Sergey, thank you for the quick response and enhancement. I will download and try this.

Thank you very much.
コメント
There are no comments made yet.
Darrin DiSimo 承諾済みの回答
Sergey,

Thanks again. Is there any way to get a 32-bit version of the ODBC driver? I am using VB6 and need the 32-bit driver.

Thank you,
Darrin
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
コメント
There are no comments made yet.
Darrin DiSimo 承諾済みの回答
Sergey,

Thank you again for the quick response. I downloaded the 32bit ODBC driver and it is working with Encrypted databases.

Now the only issue I am having is that using ADO with the .fields("Column1";) construct is returning that data with trailing null's. So if the data in Column1 is "ABC", rs.fields("Column1";) returns "ABC<null><null><null>...". The number of nulls seem to be padded out to the size of the field.

Do you have any idea if this is a setting in ADO, ODBC, or somewhere else??

Thanks again,
Darrin
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
What is the type of this field? VarChar?
コメント
There are no comments made yet.
Darrin DiSimo 承諾済みの回答
Yes. The fields are VarChar.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
As I remember the field buffers are created by the calling application, ADO in this case.
But is the string created from this data is correct?
コメント
There are no comments made yet.
  • ページ :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.