1. Thomas Goertler
  2. Valentina Database ADK
  3. 金, 3月 11 2016, 12:08 AM
  4.  メールで購読
Hi,

in our VServer database we've several tables that are linked mostly 1:M. Now when we delete a "master" record all connected records get also deleted. After the detail records are deleted it seems the "links" are still intact. Is this intended to behave like that or shouldn't the links themself also get deleted when deleting cascaded records?

We use ADK .NET with VServer connection. This can also be tested in Valentina Studio when linking some records of different tables then delete a master record. Then try to create new records and link them. You'll get an error telling that the records are already linked.

Any suggestions on this?

Best Regards,
Thomas
コメント
There are no comments made yet.
Ivan Smahin 承諾済みの回答
This sounds like a bug. Could you please report it to the Mantis and attach some test database to reproduce it?
コメント
There are no comments made yet.
Thomas Goertler 承諾済みの回答
Hi Ivan,

thank you for your reply. I'll add it soon to the bug tracker. We found out that in the first place this doesn't work when using indexes. After deleting them it worked but now something else seems not to work anymore. I'll keep you soon updated.

Regards,
Thomas
コメント
There are no comments made yet.
  • ページ :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories