1. Andrea Cinelli
  2. Valentina Reports ADK
  3. 木, 5月 26 2016, 03:18 PM
  4.  メールで購読
1- On linux web server (apache) running this code:

ds_str = DefineEncoding(ds_str, Encodings.UTF8)
sql = DefineEncoding(sql, Encodings.UTF8)

dim nameReport as String = _tipo

nameReport = DefineEncoding(nameReport, Encodings.UTF8)


mReport = mProject.MakeNewReport(nameReport,ds_str,sql)

we have back 611604 encoding error (it run on window debug)

2- picture encoded in binary (blob, mysql database) with both Xojo options (picture.getdata or encodebase64) Valentina remain blank
コメント
There are no comments made yet.
Andrea Cinelli 承諾済みの回答
We have:
vcomponents: empty folder
vcomponents_32: valentina's library files and vresources directory with error files (but not our 611604 error)
vcomponents_64: same per 32

Thanks for skype, we'll do it next week.

ciao
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Maybe you prefer to talk in skype for more quick response?
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Strange that they are empty. So do you have a copy of vcomponents folder near to executable?
コメント
There are no comments made yet.
Andrea Cinelli 承諾済みの回答
1- Datasource string: query MySQL (it run correct on Valentina studio)
2- Database MySQL is on the same host
3- Confirmed (local project w/out Valentina Server)

vcomponents: there is another folder inside (same name: vcomponents) both empty
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Need to get an error string to find out what's wrong.

Can you check please, if vresources folder is in the /usr/local/lib/vcomponents folder?

ls -l /usr/local/lib/vcomponents
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
It can be a connection problem.

Because in the latest versions of V4RB plugin at step:
mProject.MakeNewReport

only a connection to MySQL is established.

Query will be executed in report.PrintToDisk, report.PrintToBuffer, etc methods.

So
1. What datasource string do you use?
2. MySQL is at the same host?
3. Is it a local project and Valentina Server is not used?
コメント
There are no comments made yet.
Andrea Cinelli 承諾済みの回答
Yes, that what's happen.
We use UTF8 general_ci code on MySQL database
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Andrea Cinelli wrote:

1. we have check just on window debug (nor other system) - running yor code on ubuntu server (xojo build version) it doesn't work 'cause encoding seems correct on all 3 strings but same error...........



A bit unclear...
Do you develop and debug on Windows and everything is fine? And run under Apache - and get this error, right?

And what database do you use?
コメント
There are no comments made yet.
Andrea Cinelli 承諾済みの回答
Unfortunately we don't have message in the error (just error number)
コメント
There are no comments made yet.
Andrea Cinelli 承諾済みの回答
Unfortunately we don't have message in the error (just code)
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
I mean error message:

Try

....

Exception err As VException
Dim errNumber As Integer = err.ErrorNumber
Dim errString As String = err.Message
MsgBox(errString)
End
コメント
There are no comments made yet.
Andrea Cinelli 承諾済みの回答
Sergey,
do you mean error description?
'Cause we have only that one

ciao
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hi Andrea,

611604 is a datasource error number.
VException contains also an error reason right from datasource, right? What was it?
コメント
There are no comments made yet.
Andrea Cinelli 承諾済みの回答
Hi Sergey,
1. we have check just on window debug (nor other system) - running yor code on ubuntu server (xojo build version) it doesn't work 'cause encoding seems correct on all 3 strings but same error...........
2. ok done (wrong image encoding)

ciao thanks.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hi Andrea,

1. Does it happen only on Linux with Apache? Or from Xojo, too? On other systems?

After DefineEncoding call you can do checks yourself, like

If sql.Encoding = Nil Then
....
End If


Was an encoding defined?

2. You tried to show an image from MySQL database in the report, right? What was the format of this image?
コメント
There are no comments made yet.
  • ページ :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories